Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Generic Associated Channel (G-ACh) Parameters Created 2014-02-07 Last Updated 2026-09-28 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • MPLS Generalized Associated Channel (G-ACh) Types (including Pseudowire Associated Channel Types) • G-ACh Advertisement Protocol Application Registry • G-ACh Advertisement Protocol: GAP TLV Objects (Application ID 0) • G-ACh Advertisement Protocol: Ethernet Interface Parameters • CC/CV MEP-ID TLV Registry • Measurement Timestamp Type • Loss/Delay Measurement Control Code: Query Codes • Loss/Delay Measurement Control Code: Response Codes • MPLS Loss/Delay Measurement TLV Object • Return Path Sub-TLV Types • MPLS Fault OAM Message Type Registry • MPLS Fault OAM Flag Registry • MPLS Fault OAM TLV Registry • MPLS PSC Request Registry • MPLS PSC TLV Registry • MPLS PSC Capability Flag Registry • MPLS RTM TLV Registry • MPLS RTM Sub-TLV Registry • MPLS-TP DHC TLVs • MPLS RPS Request Code Registry MPLS Generalized Associated Channel (G-ACh) Types (including Pseudowire Associated Channel Types) Registration Procedure(s) IETF Review Reference [RFC 4385][RFC 5586][RFC Errata 1940][RFC 7026][RFC 7214] Available Formats [IMG] CSV Value Description Reference 0x0000 Reserved 0x0001 Management Communication Channel (MCC) [RFC 5718] 0x0002 Signaling Communication Channel (SCC) [RFC 5718] 0x0003-0x0006 Unassigned 0x0007 BFD Control, PW-ACH encapsulation (without IP/UDP Headers) [RFC 5885] 0x0008 S-BFD Control, PW-ACH/L2SS encapsulation (without IP/UDP Headers) [RFC 7885] 0x0009 MPLS-TP Dual-Homing Coordination message [RFC 8185] 0x000A MPLS Direct Loss Measurement (DLM) [RFC 6374] 0x000B MPLS Inferred Loss Measurement (ILM) [RFC 6374] 0x000C MPLS Delay Measurement (DM) [RFC 6374] 0x000D MPLS Direct Loss and Delay Measurement (DLM+DM) [RFC 6374] 0x000E MPLS Inferred Loss and Delay Measurement (ILM+DM) [RFC 6374] 0x000F Residence Time Measurement [RFC 8169] 0x0010 Time Bucket Jitter Measurement [RFC 9571] 0x0011 Multi-packet Delay Measurement [RFC 9571] 0x0012 Average Delay Measurement [RFC 9571] 0x0013 Multipoint BFD Session [RFC 9780] 0x0014 STAMP Session-Sender [RFC-ietf-mpls-stamp-pw-21] 0x0015 STAMP Session-Reflector [RFC-ietf-mpls-stamp-pw-21] 0x0016-0x0020 Unassigned 0x0021 Associated Channel carries an IPv4 packet [RFC 4385] 0x0022 MPLS-TP CC message [RFC 6428] 0x0023 MPLS-TP CV message [RFC 6428] 0x0024 Protection State Coordination Protocol - Channel Type (PSC-CT) [RFC 6378] 0x0025 On-Demand CV [RFC 6426] 0x0026 LI [RFC 6435] 0x0027 PW OAM Message [RFC 6478] 0x0028 MAC Withdraw OAM Message [RFC 7769] 0x0029 PW Status Refresh Reduction [RFC 8237] 0x002A Ring Protection Switching (RPS) Protocol [RFC 8227] 0x002B-0x0056 Unassigned 0x0057 Associated Channel carries an IPv6 packet [RFC 4385] 0x0058 Fault OAM [RFC 6427] 0x0059 G-ACh Advertisement Protocol [RFC 7212] 0x005A-0x7FF7 Unassigned 0x7FF8-0x7FFF Reserved for Experimental Use [RFC 5586] 0x8000-0x8901 Unassigned 0x8902 G.8113.1 OAM [RFC 6671] 0x8903-0xFFFF Unassigned G-ACh Advertisement Protocol Application Registry Registration Procedure(s) IETF Review Reference [RFC 7212][RFC 7214] Available Formats [IMG] CSV Application ID Description Reference 0x0000 G-ACh Advertisement Protocol [RFC 7212] 0x0001 Ethernet Interface Parameters [RFC 7213] 0x0002-0xFFFF Unassigned G-ACh Advertisement Protocol: GAP TLV Objects (Application ID 0) Registration Procedure(s) IETF Review Reference [RFC 7212][RFC 7214] Available Formats [IMG] CSV Type ID Type Name Reference 0 Source Address [RFC 7212] 1 GAP Request [RFC 7212] 2 GAP Flush [RFC 7212] 3 GAP Suppress [RFC 7212] 4 GAP Authentication [RFC 7212] 5-255 Unassigned G-ACh Advertisement Protocol: Ethernet Interface Parameters Registration Procedure(s) IETF Review or IESG Approval Reference [RFC 7213][RFC 7214] Available Formats [IMG] CSV Type ID Type Name Reference 0 Source MAC Address [RFC 7213] 1 Maximum Frame Size [RFC 7213] 2-255 Unassigned CC/CV MEP-ID TLV Registry Registration Procedure(s) Standards Action Reference [RFC 6428][RFC 7214] Available Formats [IMG] CSV Value Name Reference 0 Section MEP-ID [RFC 6428] 1 LSP MEP-ID [RFC 6428] 2 PW MEP-ID [RFC 6428] 3-255 Unassigned Measurement Timestamp Type Registration Procedure(s) IETF Review Reference [RFC 6374][RFC 7214] Available Formats [IMG] CSV Type Description Size in Bits Reference 0 Null Timestamp 64 [RFC 6374] 1 Sequence Number 64 [RFC 6374] 2 Network Time Protocol version 4 64-bit Timestamp 64 [RFC 6374] 3 Truncated IEEE 1588v2 PTP Timestamp 64 [RFC 6374] 4-15 Unassigned Loss/Delay Measurement Control Code: Query Codes Registration Procedure(s) IETF Review Reference [RFC 6374][RFC 7214] Available Formats [IMG] CSV Code Description Reference 0x0 In-band Response Requested [RFC 6374] 0x1 Out-of-band Response Requested [RFC 6374] 0x2 No Response Requested [RFC 6374] 0x3-0xFF Unassigned Loss/Delay Measurement Control Code: Response Codes Registration Procedure(s) IETF Review Reference [RFC 6374][RFC 7214] Note Values 0x0-0xF are reserved for non-error response codes; please refer to Section 4.1 of [RFC 6374] for guidelines. Available Formats [IMG] CSV Code Description Reference 0x0 Reserved [RFC 6374] 0x1 Success [RFC 6374] 0x2 Data Format Invalid [RFC 6374] 0x3 Initialization in Progress [RFC 6374] 0x4 Data Reset Occurred [RFC 6374] 0x5 Resource Temporarily Unavailable [RFC 6374] 0x6-0xF Unassigned 0x10 Unspecified Error [RFC 6374] 0x11 Unsupported Version [RFC 6374] 0x12 Unsupported Control Code [RFC 6374] 0x13 Unsupported Data Format [RFC 6374] 0x14 Authentication Failure [RFC 6374] 0x15 Invalid Destination Node Identifier [RFC 6374] 0x16 Connection Mismatch [RFC 6374] 0x17 Unsupported Mandatory TLV Object [RFC 6374] 0x18 Unsupported Query Interval [RFC 6374] 0x19 Administrative Block [RFC 6374] 0x1A Resource Unavailable [RFC 6374] 0x1B Resource Released [RFC 6374] 0x1C Invalid Message [RFC 6374] 0x1D Protocol Error [RFC 6374] 0x1E-0xFF Unassigned MPLS Loss/Delay Measurement TLV Object Registration Procedure(s) IETF Review Reference [RFC 6374][RFC 7214] Note Types 0-127 are classified as Mandatory, and Types 128-255 are classified as Optional. Available Formats [IMG] CSV Code Description Reference 0 Padding - copy in response [RFC 6374] 1 Return Address [RFC 6374] 2 Session Query Interval [RFC 6374] 3 Loopback Request [RFC 6374] 4 Synonymous Flow Label [RFC 9571] 5 Return Path [RFC 9779] 6 Block Number [RFC 9779] 7-126 Unassigned 127 Experimental use [RFC 6374] 128 Padding - do not copy in response [RFC 6374] 129 Destination Address [RFC 6374] 130 Source Address [RFC 6374] 131 UDP Return [RFC 7876] 132-254 Unassigned 255 Experimental use [RFC 6374] Return Path Sub-TLV Types Reference [RFC 9779] Available Formats [IMG] CSV Range Registration Procedures 1-175 IETF Review 176-239 First Come First Served 240-251 Experimental Use 252-254 Private Use Value Description Reference 0 Reserved [RFC 9779] 1 MPLS Label Stack of the Return Path [RFC 9779] 2-239 Unassigned 240-251 Reserved for Experimental Use [RFC 9779] 252-254 Reserved for Private Use [RFC 9779] 255 Reserved [RFC 9779] MPLS Fault OAM Message Type Registry Registration Procedure(s) Standards Action Reference [RFC 6427][RFC 7214] Available Formats [IMG] CSV Msg Type Description Reference 0 Reserved [RFC 6427] 1 Alarm Indication Signal (AIS) [RFC 6427] 2 Lock Report (LKR) [RFC 6427] 3-251 Unassigned 252-255 Reserved for Experimental Use [RFC 6427] MPLS Fault OAM Flag Registry Registration Procedure(s) Standards Action Reference [RFC 6427][RFC 7214] Available Formats [IMG] CSV Bit Hex Description Reference 0-5 Unassigned 6 0x2 L-Flag [RFC 6427] 7 0x1 R-Flag [RFC 6427] MPLS Fault OAM TLV Registry Expert(s) Unassigned Reference [RFC 6427][RFC 7214] Available Formats [IMG] CSV Range Registration Procedures 0-191 Standards Action 192-247 Specification Required Value TLV Name Reference 0 Reserved [RFC 6427] 1 Interface Identifier TLV [RFC 6427] 2 Global Identifier [RFC 6427] 3-247 Unassigned 248-255 Reserved for Experimental Use [RFC 6427] MPLS PSC Request Registry Registration Procedure(s) Standards Action Reference [RFC 6378][RFC 7214] Available Formats [IMG] CSV Value Description Reference 0 No Request [RFC 6378] 1 Do-not-Revert [RFC 6378] 2 Reverse Request [RFC 7271] 3 Exercise [RFC 7271] 4 Wait-to-Restore [RFC 6378] 5 Manual Switch [RFC 6378] 6 Unassigned 7 Signal Degrade [RFC 6378] 8-9 Unassigned 10 Signal Fail [RFC 6378] 11 Unassigned 12 Forced Switch [RFC 6378] 13 Unassigned 14 Lockout of protection [RFC 6378] 15 Unassigned MPLS PSC TLV Registry Registration Procedure(s) IETF Review Reference [RFC 6378][RFC 7214] Available Formats [IMG] CSV Value Description Reference 0 Reserved, not to be allocated [RFC 6378][RFC 7324] 1 Capabilities [RFC 7271] 2-65535 Unassigned MPLS PSC Capability Flag Registry Registration Procedure(s) Standards Action Reference [RFC 7271] Available Formats [IMG] CSV Bit Hex Value Capability Reference 0 0x80000000 priority modification [RFC 7271] 1 0x40000000 non-revertive behavior modification [RFC 7271] 2 0x20000000 support of MS-W command [RFC 7271] 3 0x10000000 support of protection against SD [RFC 7271] 4 0x08000000 support of EXER command [RFC 7271] 5-31 Unassigned MPLS RTM TLV Registry Reference [RFC 8169] Available Formats [IMG] CSV Range Registration Procedures 0-127 IETF Review 128-191 First Come First Served Value Description Reference 0 Reserved [RFC 8169] 1 No payload [RFC 8169] 2 PTPv2, Ethernet encapsulation [RFC 8169] 3 PTPv2, IPv4 encapsulation [RFC 8169] 4 PTPv2, IPv6 encapsulation [RFC 8169] 5 NTP [RFC 8169] 6-191 Unassigned 192-254 Reserved for Private Use [RFC 8169] 255 Reserved [RFC 8169] MPLS RTM Sub-TLV Registry Reference [RFC 8169] Available Formats [IMG] CSV Range Registration Procedures 0-127 IETF Review 128-191 First Come First Served Value Description Reference 0 Reserved [RFC 8169] 1 PTP [RFC 8169] 2-191 Unassigned 192-254 Reserved for Private Use [RFC 8169] 255 Reserved [RFC 8169] MPLS-TP DHC TLVs Registration Procedure(s) IETF Review Reference [RFC 8185] Available Formats [IMG] CSV Type Description Length Reference 0x0000 Reserved [RFC 8185] 0x0001 PW Status 20 bytes [RFC 8185] 0x0002 Dual-Node Switching 16 bytes [RFC 8185] 0x0003-0xFFFF Unassigned MPLS RPS Request Code Registry Registration Procedure(s) Specification Required Expert(s) Weiqiang Cheng, Jie Dong Reference [RFC 8227] Available Formats [IMG] CSV Value Description Reference 0 No Request (NR) [RFC 8227] 1 Reverse Request (RR) [RFC 8227] 2 Unassigned 3 Exercise (EXER) [RFC 8227] 4 Unassigned 5 Wait-to-Restore (WTR) [RFC 8227] 6 Manual Switch (MS) [RFC 8227] 7-10 Unassigned 11 Signal Fail (SF) [RFC 8227] 12 Unassigned 13 Forced Switch (FS) [RFC 8227] 14 Unassigned 15 Lockout of Protection (LP) [RFC 8227] 16-254 Unassigned 255 Reserved [RFC 8227] Licensing Terms